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Introduction

This tutorial is designed to expose you to basic functions in HEC-GeoHMS (ArcGIS 10.x
version) to create input files for hydrologic modeling with HEC-HMS. It is expected that you are
familiar with HEC-HMS and ArcGIS. If you want to get into details of HEC-GeoHMS that are
not covered in this tutorial please refer to the HEC-GeoHMS users manual. If you are continuing
this exercise as a part of earlier terrain processing using ArcHydro or GeoHMS, you can briefly
look over pages 1 and 2, and the actual work will from the bottom of Page 3 (GeoHMS project
set-up)

Getting Started

Open ArcMap that you created in the previous lab using Archydro Tools. Save the map
document. Right click on the menu bar to pop up the context menu showing available tools as
shown below.

eodatabase Hiskory
Gaeomekric Metwork Editing
Geareferencing
Gaenskatistical Analyst
araphics

| HEC-GeoHMS

HEZ-GeoRAS

Check the HEC-GeoHMS menu.

You should now see the HEC-GeoHMS toolbar added to ArcMap as shown below. You can
leave it floating or you may dock it in ArcMap.

Preprocessing ~ Project Setup = Basin Processing = Charackeristics = Parameters = HMS « Utility - & t- A B 2 | Reservoir v ? Help

Note: It is not necessary to load the Spatial Analyst, Utility Network Analyst, or Editor tools
because Arc Hydro Tools will automatically use their functionality on as needed basis. These
toolbars need to be activated though if you want to use any general functionality that they
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provide (such as general editing functionality or network tracing). The Spatial Analyst Extension
can be activated, by clicking Customize->Extensions..., and checking the box next to Spatial
Analyst.

Dataset Setup

All vector data created with GeoHMS will be stored in a new geodatabase that has the same
name as the stored project or ArcMap document (unless pointed to an existing geodatabase) and
in the same directory where the project has been saved (your working folder). By default, the
new raster data are stored in a subdirectory with the same name as the dataset or Data Frame in
the ArcMap document (called Layers by default and under the directory where the project is
stored). The location of the vector, raster, and time series data can be explicitly specified using
the function ApUtilities—> Set Target Locations.

You can leave the default settings if they are pointing to the same directory where the ArcMap
document is saved.

Terrain Preprocessing

Terrain processing involves using the DEM to create a stream network and catchments. The
Processing menu (shown below) in HEC-GeoHMS is used for terrain processing. You have
already used these tools from the ArcHydro menu in the previous exercise so no need to repeat.
Just take a look at the sequence to refresh your memory.

Preprocessing = | Project Setup = Basin Proo

Daka Managermenk

DEM Reconditioning
Build ‘walls
Fill Sinks

Flova Direction

Flow Accurmulation
Stream Definition
Stream Segmentation

Catchment Grid Delineation
Catchrment Palvgon Processing
Drainage Line Processing

Adjoint Catchment Processing

From Terrain Processing using Arc Hydro Tools, you should have the following dataset in your
map document.

Raster Data



Raw DEM

HydroDEM (DEM after reconditioning and filling sinks)
Flow Direction Grid

Flow Accumulation Grid

Stream Grid

Stream Link Grid

Catchment Grid

Slope Grid

NGO~ wWNE

Vector Data

1. Catchment Polygons

2. Drainage Line Polygons

3. Adjoint Catchment Polygons

This concludes the terrain processing part. What you have produced is a hydrologic skeleton that can now
be used to delineate watersheds or sub-watersheds for any given point on the delineated stream network.
The next part of this tutorial involved delineating a watershed to create a HEC-HMS model using HEC-
GeoHMS. Save your map document.

HEC-HMS Modeling Development using HEC-GeoHMS

Before you continue, please make sure you have the following datasets in the map document
from the previous part.

Rasters

Cedar_dem (raw DEM)

Fil (filled DEM)

Fdr (flow direction grid)

Fac (flow accumulation grid)

Str (stream network grid)

StrLnk (stream link grid) (Note: earlier version of ArcHydro names this grid as Lnk)
Cat (catchment grid)

WshSlope (slope grid)

NGO~ wWdE

Vectors

1. Catchment

2. DrainageLine

3. AdjointCatchment

Save the map document.
HEC-GeoHMS Project Setup

The HEC-GoeHMS project setup menu has tools for defining the outlet for the watershed, and
delineating the watershed for the HEC-HMS project. As multiples HMS basin models can be
developed by using the same spatial data, these models are managed by defining two feature
classes: ProjectPoint and ProjectArea. Management of models through ProjectPoint and



ProjectArea let users to see areas for which HMS basin models are already created, and also
allow users to re-create models with different stream network thresholds. It is also convenient to
delete projects and associated HMS files through ProjectPoint and ProjectArea option.

Dataset Setup

Select HMS Project Setup—~> Data Management on the HEC-GeoHMS Main View toolbar.
Confirm/define the corresponding map layers in the Data Management window as shown
below:

#! Data Management.

Fav DEM | cedar_dem i |
Hydra DEM i v |
Flawy Direction Grid | fdr v |
Flaws Accumulation Grid | fac v |
Stream Grid | shr v |
Stream Link Grid | stilnk v |
Catchment | Catchment v |

Adijoint Catchment

Froject Paint

Froject frea

[ OK ” Help ][ Qancel]

Click OK.

Creating New HMS Project

Click on Project Setup-> Start New Project. Confirm ProjectArea for ProjectArea and
ProjectPoint for ProjectPoint, and click OK.

£ Start New Project

Froject Area | Projectfres |
Froject Paint | PrajectPaint |
oK ] [ Help ] [ Cancel ]




(Note: For some reason, if you get an error message about accuracy/resolution of the data, this
has to do with tolerances for x,y,m,z coordinates in your spatial coordinates which you need to
fix in ArcCatalog)

This will create ProjectPoint and ProjectArea feature classes. In the next window, provide the
following inputs:

B¥ pefine a New Project g|
Project Marne CedarCreek W D
Description HMS Model for Cedar Creek
E xtraction Method Original Stream Definition w

Metadata for Project:

This project iz created using HECGeoHMS for ArcGlS 10. The stream
network threshold used iz 25 km?2]

Froject D ata Location

() Inside Mairview Geodatabaze

(%) Dutside Mairiview Geodatabase D

Target: | D:Mrc10geohms

| ok | [ Hep | | cance |

If you click on Extraction Method drop-down menu, you will see another option “A new
threshold” which will delineate streams based on this new threshold for the new project. For now
accept the default original stream definition option. You can write some metadata if you wish,
and finally choose the outside MainView Geodatabase for Project Data Location, and browse to
your working directory where cedar.mxd is stored. Click OK.

Click OK on the message regarding successful creation of the project. You will see that new
feature classes ProjectArea and ProjectPoint are added to ArcMap’s table of contents. These
feature classes are added to the same geodatabase cedar.gdb.

Next Zoom-in to downstream section of the Cedar creek to define the watershed outlet as shown
below:



&

Select the Add Project Points tool ’? on the HEC-GeoHMS toolbar, and click on the
downstream outlet area of the Cedar Creek to define the outlet point as shown below as red dot:

W Project Points for CedarCreek

Point M ame |Dutlet1 |
Description | Qe |
[ k. ] [ Help ] [ Cancel ]

Accept the default Point Name and Description (Outlet), and click OK. This will add a point for
the watershed outlet in the ProjectPoint feature class. Save the map document.

Next, select HMS Project Setup—> Generate Project. This will create a mesh (by delineating
watershed for the outlet in Project Point), and display a message box asking if you want to create
a project for this hatched area as shown below:
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(Note: This part could be challenging sometimes. If you face problem in creating Project Area,

just delineate a watershed using the point delineation tool * in Arc Hydro for the Project Point
feature, and load this watershed polygon into ProjectArea feature class. Make sure the HydrolD
of ProjectArea is same as ProjectID of ProjectPoint. Also you need to make sure the name and
description match with each other)

Click Yes on the message box. Next, confirm the layer names for the new project (leave default
names for Subbasin, Project Point, River and BasinHeader), and click OK.



' Generate Project

M airiiewDE tairtigwD E
Faw DEM RawDEM
Hydra DEM Fil
Flaws Direction Grid Fdr
Flawe Accurnulation Grid Fac
Stream Grid Str
Stream Link Grid Stilrk,
Catchrnent Grid Cat
Subbasin Subbasin
Project Point ProjectPaint1
River Riverl

[ oK ] [ Help ] [ Cancel ]

This will create a new folder inside your working folder with the name of the project
CedarCreek, and store all the relevant raster, vector and tabular data inside this folder. The
raster data are stored in a sub folder with the project name (CedarCreek) inside CedarCreek
folder. All vector and tabular data are stored in CedarCreek.mdb. You will also notice that a new
data frame (CedarCreek) is added in ArcMap containing data for cedar creek.

You can also play with the contributing area tool | ¥ 1o find out contributing area at different
points along the Cedar creek stream network. With Ink grid active, select the contributing area
tool, and click at any point along the stream to know the contributing area.

Save the map document.
Basin Processing

The basin processing menu has features such as revising sub-basin delineations, dividing basins,
and merging streams.

Merge Basins

This process merges two or more adjacent basins into one. Zoom-in to the area marked in the
rectangle below:
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Select the three adjacent basins (shown above) using the standard select tool LP. Click on Basin
Processing—> Basin Merge. You will get a message asking to confirm the merging of selected
basins (with basins hatched in background), click Yes. Similarly merge two more sub-basins as
shown below:

As a result of this merging, we now have 13 sub-basins and 15 river segments in the project.
Save the map document.

River Profile

(Note: we will only look at the functionality of river profile tool, and not split river/basin using
this tool.)

The River Profile tool e allows displaying the profile of selected river reach(es). If the river
slope changes significantly over the reach length, it may be useful to split the river/watershed at



such a slope change. Select the River Profile tool e , and click on any river segment that you
are interested in inspecting. Confirm the layers in the next window, and click OK. This will
invoke a dockable window in ArcGIS at the bottom that will display the profile of the selected
reach. If you click at a point along the profile, a corresponding point showing its location on the
river reach will be added to the map display (shown below as red dot).
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If you want to split the river segment at the selected point, you can just right click on the point
inside the dockable window and split the river. If you want to split the sub-basin at the point

displayed in the map, you can use the subbasin divide Al tool, and click at the point displayed on
the map. We will not split any river segments in this exercise.

Close the dockable window, and save the map document.

Extracting Basin Characteristics

The basin characteristics menu in the HEC-GeoHMS Project View provides tools for extracting
physical characteristics of streams and sub-basins into attribute tables.

River Length

This tool computes the length of river segments and stores them in RiverLen field. Select
Characteristics>River Length. Confirm the input River name, and click OK.

“\\ River Length

Input River

~
|River1 ﬂ

W

[ oK l [ Cancel ] [Environments... ] [ Show Help == ]

10



You can check the RiverLen field in the input Riverl (or whatever name you have for your input
river) feature class is populated. Save the map document.

River Slope

This tool computes the slope of the river segments and stores them in Slp field. Select Basin
Characteristics>River Slope. Confirm inputs for RawDEM and River, and click OK.

"\ River, Slope E| E| E|
Input Raw DEM e
| rawDEM =]
Input River
| river1 =

v
[ oK l [ Cancel l [Envimnments... l [ Show Help = l

You can check the Slp field in the input Riverl (or whatever name you have for your input river)
feature class is populated. Fields ElevUP and ElevDS are also populated during this process. Slp
= (ElevUP — ElevDS)/RiverLen.

Basin Slope
This tool computes average slope for sub-basins using the slope grid and sub-basin polygons.

Add wshslope (percent slope for watershed) grid to the map document. Select
Characteristics>Basin Slope. Confirm the inputs for Subbasin and Slope Grid , and click OK.

“\ Basin Slope E|E|El

Input Slope Grid
|Wsh5|0pe ﬂ @
Input Subbasin
|Subbasin1 ﬂ @

[ o]4 l [ Cancel ] [Envimnments... ] [ Show Help == ]

After the computations are complete, the BasinSlope field in the input Subbasin feature class is
populated.

Longest Flow Path
This will create a feature class with polyline features that will store the longest flow path for

each sub-basin. Select Characteristics=>Longest Flow Path. Confirm the inputs, and leave the
default output name LongestFlowPath unchanged. Click OK.

11



“\ Longest Flowpath

Input Raw DEM
|RawDEM |
Input Flow Direction Grid
[Far ~
Input Subbasin
|Subbasin1 ﬂ
Output Longest Flow Path
[harcl 0 gechmstCedarCreek) CedarCreek. gdb CedarCreekiLongestFlowPath152

I Ok l [ Cancel ] ’Environments... ] ’ Show Help == ]

A new feature class storing longest flow path for each sub-basin is created as shown below.

Open the attribute table of Longest Flow Path, and examine its attributes. Close the attribute
table, and save the map document.

Basin Centroid

This will create a Centroid point feature class to store the centroid of each sub-basin. Select
Characteristics>Basin Centroid. Choose the default Center of Gravity Method, input Subbasin,
leave the default name for Centroid. Click OK.

(Note: Center of Gravity Method computes the centroid as the center of gravity of the sub basin
if it is located within the sub basin. If the Center of Gravity is outside, it is snapped to the closest
boundary. Longest Flow Path Method computes the centroid as the midpoint of the longest flow
path within the sub basin. The quality of the results by the two methods is a function of the shape
of the sub basin and should be evaluated after they are generated.)

12



“\ Basin Centroid

Select Centroid Method

| Center of gravity vl
Input Subbasin

|Subbasin1 ﬂ
Cutput Centroid

| Dyarcl0lgechmstCedar Creek)CedarCreek, gdblCedarCreek) Centroid 152 |

Input Flove Accumulation Grid (optional)

| = 2]

Input River {optional)

| = 2]

Input Longest Flows Path {optional)

| = ]

Ok ] [ Cancel ] [Environments... ] [ Show Help == ]

A point feature class showing centroid for each sub-basin is added to the map document.

As centroid locations look reasonable, we will accept the center of gravity method results, and
proceed. Save the map document.

Basin Centroid Elevation
This will compute the elevation for each centroid point using the underlying DEM. Select

Characteristics—>Centroid Elevation. Confirm the input DEM and centroid feature class, and
click OK.

"\ Centroid Elevation

”~
Input Raw DEM
| rawDEM |
Input Centroid
| Centroid152 =

v

Ok ] [ Cancel ] [Environments‘.. ] [ Shows Help == ]
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After the computations are complete, open the attribute table of Centroid to examine the
Elevation field.

Centroidal Longest Flow Path

Select Characteristics=> Centroidal Longest Flow Path. Confirm the inputs, and leave the
default name for output Centroidal Longest Flow Path, and Click OK.

"\ Centrpidal Longest Flowpath

Input Subbasin

|Subbasin1 ﬂ g
Input Centroid

| Centraidisz | @
Input Longest Flow Path

|L0ngestFIOwPath152 ﬂ @

Cutput Centroidal Longest Flow Path
narciOgechms| CedarCreekh CedarCreek. gdbt CedarCreekiCentroidalLonge stFlowF

[ (o] 4 ] [ Cancel ] [Environments... ] [ Show Help == ]

This creates a new polyline feature class showing the flowpath for each centroid point along
longest flow path. Save the map document.

HMS Inputs/Parameters

The parameters menu in HEC-GeoHMS provides tools to estimate and assign a number of
watershed and stream parameters for use in HMS. These parameters include SCS curve number,
time of concentration, channel routing coefficients, etc.

Select HMS Processes

You can specify the methods that HMS should use for transform (rainfall to runoff) and routing
(channel routing) using this function. Of course, this can be modified and/or assigned inside
HMS.

Select Parameters—-> Select HMS Processes. Confirm input feature classes for Subbasin and
River, and click OK. Choose SCS for Loss Method (getting excess rainfall from total rainfall),
SCS for Transform Method (for converting excess rainfall to direct runoff), None for Baseflow
Type, and Muskingum for Route Method (channel routing). Click OK.

14



N\ Select HMS Processes M=11E3

Input Subbasin

|Subbasin1| j

Inpuk River

|River1 j

Subbasin - Loss Method

E= v|

Subbasin - Transform Method

505 v|

Subbasin - Baseflow Method

| Mone w |

River - Route Method

| Muskingum R |
[ (o] 4 ] [ Cancel ] [Environments. . ] [ Show Help == ]

You can open the attribute table of subbasin feature class to see that the subbasin methods are
added to LossMet, TransMet, and BaseMet fields, respectively. The Muskingum method is added
to RouteMet field in the River feature class. You can treat these methods as tentative which can
be changed in HMS model. Save the map document.

River Auto Name

This function assigns names to river segments. Select Parameters->River Auto Name. Confirm
the input feature class for River, and click OK.

“\ River Auto Name |Z||E|E|
M~

Input River =
|River1 j =

)

[ Ok l [ Cancel l [Envir-:-nments... l [ Show Help ==

The Name field in the input River feature class is populated with names that have “R###”
format, where “R” stands for river/reach “###” is an integer.

Basin Auto Name

This function assigns names to sub-basins. Select Parameters—>Basin Auto Name. Confirm the
input feature class for sub-basin, and click OK.

“\, Basin Auto Name EE
g SRS e

[ subbasint 4| E

bt

ok || cancel | [Environments... | [ Showhelp=> |

15



Like river names, the Name field in the input Subbasin feature class is populated with names that
have “W###” format, where “W” stands for watershed, and “###” is an integer. Save the map
document.

Sub-basin Parameters

Depending on the method (HMS process) you intend to use for your HMS model, each sub-basin
must have parameters such as SCS curve number for SCS method and initial loss constant, etc.
These parameters are assigned using Subbasin Parameters option. This function overlays
subbasins over grids and compute average value for each basin. We will explore only those
parameters that do not require additional datasets or information.

Add cngrid (curve number grid) from Layers folder to the map document. Select
Parameters—>Subbasin Parameters from Raster. You will get a window in which you will have
to select the rasters that you want to use for extracting parameters. In this case, we will only
extract the CN number for each basin from a curve number grid. Accordingly, select the cngrid
for the Input Curve Number Grid, and and Click OK.

"\, Subbasin Parameters From Raster

Input Subbasin

|Subbasin1 ﬂ @

Input Total Storm Precipitation {optional)

| R=

Input 2-¥ear Rainfall Grid {optional)

| = g

Input Percentage Impervious Grid (optional)

| = g

Input Initial Abstraction Grid {optional)

| = g

Input Curve Mumber Grid {optional)

| cngrid ﬂ
¥

’ o4 ] ’ Cancel l [Environments... ] ’ Show Help == l

After the computations are complete, you can open the attribute table for subbasin, and see that a
field named BasinCN is populated with average curve number for each sub-basin. Close the
attribute table, and save the map document.

(Note: We will skip parameters associated with computing rainfall as these numbers should

come from detailed analysis of the watershed. However, if you are interested, you can explore
these functions if you have all the necessary data for their execution.)

16



SCS Curve Number is extracted using a grid, but parameters can also be extracted by using a
feature class and its intersection with subbasins by using the Subbasin Parameters from Features
option, but this option is not described in this exercise.

CN Lag Method

The function computes basin lag in hours (weighted time of concentration or time from the
center of mass of excess rainfall hyetograph to the peak of runoff hydrograph) using the NRCS
National Engineering Handbook (1972) curve number method. Select Hydrologic
Parameters—=>CN Lag Method. This function populates the BasinLag field in the subbasin feature
class with numbers that represent basin lag time in hours. Save the map document.

Take a look at attribute tables of River and Subbasin feature class to see what fields are
populated, and what they mean in hydrologic modeling.

HMS
The HMS menu has tools for creating input files for HEC-HMS.

Map to HMS Units

This tool is used to convert units. Click on HMS ->Map to HMS Units. Confirm the input files,
and click OK.

£ Map to HMS Units

Raw DEM RawDER b

Subbasin Subbasinl b

Longest Flow Path LongestFlowPath1 52 A

LCentroidal Longest Flow Path CentroidalLongestFlowPath152  »

River Riiverl .

Centroid Centroid152 b
oK | [ Help ] [ Cancel ]

(Note: Due to some unknown reasons, if you get an error message at this point saying field
cannot be added to a layer, save the map document, exit ArcMap and open the document, and try
again)

In the next window, choose English units (default) from the drop-down menu, and click OK.

17



B Select unit type for HMS Model @

Select the Unit type for HMS Unit Conversion

akK Help Cancel

After this process is complete, you will see new fields in both River and Subbasin feature classes
that will have fields ending with “ HMS” to indicate these fields store attributes in the specified
HMS units (English in this case). All fields that store lengths and areas will have corresponding
“ HMS?” fields as a result of this conversion.

Check Data

This tool will verify all the input datasets. Select HMS >Check Data. Confirm the input datasets
to be checked, and click OK.

You should get a message after the data check saying the check data is completed successfully as
shown below.

Check Data |§|
HMS check data is completed,

Wiould vwou like to see logFile ¢
LogFile=D:4arc 10geohms CedarCreek) SkelConstCheck. kxk

Lves J[ two |

You can also look at the log file and make sure there are no errors in the data by scrolling to the
bottom of the log file as shown below.

CHECEIMNG SUMMARY

TOHOHOHOH OO OO OO OO OO

Unigue names

River containment
Center containment
River connectivity
VIP relevance

tio problems.
no problems.
no problems,
no problems.
no problems.

If you get problems in any of the above four categories (hames, containment, connectivity and
relevance), you can look at the log file to identify the problem, and fix it by yourself. This
version of HecGeoHMS apparently gives error with river connectivity even if the rivers are well
connected. Therefore, check the data carefully, and if you think everything is OK, ignore the
errors (if you get any for connectivity) and proceed.
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HMS Schematic

This tool creates a GIS representation of the hydrologic system using a schematic network with
basin elements (nodes/links or junctions/edges) and their connectivity. Select HMS—>HMS
Schematic. Confirm the inputs, and click OK.

£ HMS Schematic

Project Pain FrojectPoint] b’
Centroid Centroid152 b
River Riverl 4
Subbasin Subbasin b’
HMSLink152 Ht5Link152

Hi5SMode152 Ht5MNode152

0K | [ Help ] [ Cancel ]

Two new feature classes HMS Link and HMSNode will be added to the map document.

HM3Mods152
#® <all other values>
Mode Type
Watershed Node
# Junction Node
HMSLink152
— <all other values>
Link Type
Watershed Link
— Junction Link

After the schematic is created, you can get a feel of how this model will look like in HEC-HMS
by toggling/switching between regular and HMS legend. Select HMS—>Toggle HMS
Legend—>HMS Legend

19



: HM3Nade152
#  <all other values=>
HM3 Symbalagy

(3 piversion
EIﬂ Junction

|| Reservair

& sink

lTI Source

l%‘-. Subbasin

You can keep whatever legend you like. Save the map document.
Add Coordinates
This tool attaches geographic coordinates to features in HMSLink and HMSNode feature classes.

This is useful for exporting the schematic to other models or programs without losing the
geospatial information. Select HMS—>Add Coordinates. Confirm the input files, and click OK.

#! Add Coordinates

Faw DEM RawDEM M

HMSMode152 HMSHada152 ~

HM5Link152 HiSLink152 4
[iT4 ] [ Help ] [ Cancel

The geographic coordinates including the “z” coordinate for nodes are stored as attributes
(CanvasX, CanvasY, and Elevation) in HMSLink and HMSNode feature classes.

Prepare Data for Model Export

Select HMS—>Prepare Data for Model Export. Confirm the input Subbasin and River files, and
click OK.

Prepare Data for, Model Export

Subbasin |Subbasint

Led L

River |F|iver1

1] 4 | Help ‘ Cancel ‘
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This function allows preparing subbasin and river features for export.
Background Shape File

Select HMS—->Background Shape File. This function captures the geographic information (X,y)
of the subbasin boundaries and stream alignments in a text file that can be read and displayed
within HMS. Two shapefiles: one for river and one for sub-basin are created in the project folder.
Click OK on the process completion message box.

Basin Model

Select HMS—>Basin Model File. This function will export the information on hydrologic
elements (nodes and links), their connectivity and related geographic information to a text file
with .basin extension. The output file CedarCreek.basin (project name with .basin extension) is
created in the project folder. Click OK on the process completion message box.

You can also open the .basin file using Notepad and examine its contents.

I CedarCreek - Notepad g@@
File Edit Format Wiew Help
Basin: Cedarcreek ~

Description: HMS Model for Cedar Creek
Last Modified Date: 6/30/2008
Last Modified Time: 11:00:02
version: 3.2.0
unit system: English
Grid cell File: cedarcreek.mod
mMissing Flow To Zero: Mo
Enable Flow Ratio: Mo
Allow Blending: Mo
4 Compute Local Flow At Junctions: Mo
End:

Subbasin: w3lo
Description:
Canvas X: 638813.6956031462
Canvas Y: 4366675, 75032761
Label x: 16
Label v: 16
Area: 6.32981493
Downstream: outletl
LossRate: SCS
Percent Impervious Area: 0
Curve Number: F8.85059
Initial ahstraction: 0
Transform: scs
Lag: 143, 27531972000002
Baseflow: Mone

End: v

Meteorologic Model

We do not have any meteorologic data (temperature, rainfall etc) at this point. We will only
create an empty file that we can populate inside HMS. Select HMS—>Met Model File—> Specified
Hyetograph. The output file CedarCreek.met (project name with .met extension) is created in the
project folder. Click OK on the process completion message box.

You can also open the .met file using Notepad and examine its contents.
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Save the map document. You have successfully created a HEC-HMS project for Cedar Creek.
Congratulations! In the following part, you will open this project in HEC-HMS.

Opening the HMS Model

This section briefly explains how to interface or open the project files created by GeoHMS using
HMS.

Open HEC-HMS, and select File>New. Create a new project called CedarCreek using US
Customary unit in your working directory.

&2 Create a Mew Project @

Mame: [CedarCreek
Description; |HMS Madel For Cedar Creek @
Location: |E:vwarkiClasses

Defaulk Unit Syster: :LI.S. Custarnary v:

’ Create H Cancel ]

Next, go to File=> Import->Basin Model, and browse to the .basin file and add it to the project.
Save the project. You will see the basin folder in the left window, click on the + sign to open the
folder and click on the basin to see the Cedar Creek basin. Click on View->Background Map,
and then add the river and basin shapefiles to see the watershed as shown below.

basin along with its sub-basins, streams, links and junctions as shown below.

#2 Basin Model [CedarCreek]

Wil 6D
W1e0
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If you expand the CedarCreek basin in watershed explorer, you will see the list of junctions,
reaches and subbasins. You can click on any reach and see its associated methods. For example,
when you click on a Reach (R##), you will see that Muskingum routing method is associated
with it. Similarly, if you click on a Watershed (W##), you will see SCS Curve Number (for
abstractions) and SCS Unit Hydrograph (for runoff calculations) are associated with it. Again, if
you click on SCS Curve Number, you will see corresponding parameters in the Component
Window as shown below. All this information, which is now independent of GIS, is extracted
from attributes that we created in HEC-GeoHMS.

+- 1y W 1L

Fl-1 WEOD

i W190

i W1ED

i W17
Mo Canopy
Mo Surface
SIC5 Curve Number
SC5 Unit Hydrograph
Mo Baseflow

-5y WA

7% Outlet 1

¥ 149

J::Tf:l 52

J::Tf:l 155

J::Tf:l 155

J::Tf:l 167

J::Tf:l 177

J::Tf:l 151

= t"lf" R30

Muskingur

Mo Channel Loss

+-{5 R70

-] [

Components | Compute | Resulks

15s Subbasin | Loss | Transform | Options

Basin Mame: CedarCreek
Element Mame: Y170

Initial Abskrackion (IM)
*Curve Mumber: |73.807

*FImpervious {%)

Manipulating data in HMS, populating the Meteorologic file, and running the model is beyond
the scope of this tutorial, and will be covered in other tutorial. Save your HMS project.

OK, you are done for now!!
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