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The objective of this module is to learn some of the basic functionalities of QSWAT, and to use it 

to create a SWAT model for a watershed. SWAT is a popular model among many watershed 

hydrologists who are interested in studying the impact of agricultural activities and land use 

management on the overall watershed health including streamflow and water quality. This exercise 

is developed by using data for Cedar Creek Watershed in northeast Indiana, but the process can be 

replicated for any other watershed in the United States by using a digital elevation model (DEM), 

landuse data and soil data.  

Learning Outcomes  

Create a QSWAT project 

Delineate sub-basins and hydrologic response units in QSWAT 

Create input files for SWAT using QSWAT 

Set-up and run SWAT simulation 

Visualize SWAT Results 

 

Computer Requirements  

You must have a computer with latest windows operating system, and the following programs 

installed:  

1. QGIS 3.1x 

2. SWAT Editor 2012  

3. QSWAT3 v1.1 

4. SWAT Check 1.2.0.10 

 

For your personal computers, all these related programs, including their installation instructions, 

can be found at the following link: https://swat.tamu.edu/software.  

Data Requirements and Description 

This tutorial requires the following datasets for the study area: 

(1) DEM (NED 1 arc second ~ 30 m data) 

(2) Landuse Map (NLCD 2011 data)  

(3) Soil Data (STATSGO2) 

(4) Outlet point 
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You can get the data for Cedar Creek from the following link: 

ftp://ftp.ecn.purdue.edu/vmerwade/download/data/qswat.zip. Copy and unzip the data in your 

project folder.  

 
[If you are using this tutorial as a guide for another watershed, make sure that your raster data have 

some buffer around the study area, and all raster data are in TIFF format] 

 

Adding Soil Data 
 

SWAT requires the data for the soils in the watershed. This is stored in an .mdb file 

SWAT_US_SSURGO_Soils.mdb. In this exercise, we are using STATSGO2 soil data. Both, 

SSURGO and STATSGO2 use the same database and it can be obtained from the SWAT website. 

It is stored on the ArcSWAT page at: http://swat.tamu.edu/software/arcswat/ (you can also find a copy 

in the zipped data folder). Place the .mdb file (SWAT_US_SSURGO_Soils.mdb) in the Databases 

subfolder of the SWAT Editor folder (C:\SWAT\SWATEditor\Databases). QSWAT can find it 

and pass it to the SWAT Editor for generating the soil input files. If you are unable to access and 

store the .mdb file on C:\ drive, save it in your folder and make sure you specify the correct path 

in the SWAT project (described later). 

 

Instructions 

 

Open QGIS 3.x Desktop to create an empty document. After installation, QSWAT toolbar may 

not appear in the toolbar. To enable QSWAT, navigate to Plugins→Manage and Install Plugins. 

Select Installed tab on the left and check the QSWAT plugin as shown below. 

  

 

Close the window and you will notice that SWAT button appears on the toolbar. 

1 

2 
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Checking the Projection 

 

Add digital elevation model (DEM), landuse and soil data to the map document. Check that all the 

datasets are in same projected coordinate system (NAD1983 UTM 16 N for this tutorial). To add 

raster data, go to Layer→ Add Layer→Add Raster Layer. The STATSGO soil data may appear 

with only one color (white), but can uncheck this layer  or move other layers (using right click) to 

see other datasets. Next, add the outlet shapefile to the map document. The outlet point shapefile 

is needed only to delineate the outlet point in the watershed delineation step. If you know the 

location of the outlet on the map, you do not need the point shapefile. To add vector data, go to 

Layer→Add Layer→ Add Vector Layer. 

Project Setup 

Click the SWAT icon ( ) in the toolbar. This will open a new window where you can either 

create a new project or select an existing project (this window is called QSWAT main form). Go 

ahead and click on New Project (name it as cedar_swat) and save it in your working directory. 

After you save the project in the working directory, the Main Steps frame below the Select Project 

frame becomes activated. You will notice that Step 1 is now active and other two are still inactive. 

Also, you will see location of your working directory in the bottom left corner. 

 

 
 

Now, you will notice that a QGIS project and a folder is created in your working directory with 

the same name. In windows explorer, if you open the folder, you will see few folders  and databases 

are created in this folder as shown below. 

Q1. Go to your project folder and note what new folders or databases are created. Write down the 

name of these databases and folders. Some folders will also have sub-folders. Write down their 

names and the name of the folder under which they are created. 
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At a later stage, all these folders will hold the data you will create in this project. Without creating 

any data, it is interesting to observe that the size of QSWATRef2012.mdb file has a considerable 

size.  
 

Click on Delineate Watershed (Step 1) and a new window opens as below.  

 

 
 
Firstly, select (#1) the projected digital elevation model (DEM) for Cedar Creek, which is 

available in the data folder (cedar_dem.tif). A copy of the DEM will be added to the Source 

folder. If you look in the DEM properties tab, you will notice properties of the selected DEM. 

Now, go back to Delineate Watershed tab. In the Define threshold text box (#2), number of cells 

will be populated automatically based on the DEM that was provided in the earlier step. This 

critical stream area threshold will be used to define the stream network. We will use 27777 cells 

(25 km2) as the area, which is equivalent to 2500 Ha. 
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<Note: The threshold area of 25 km2 (2500 Ha) is approximately 3.5% of the Cedar Creek 

watershed area. Make sure you use appropriate percentage area threshold for your own watershed. 

Blindly using 25 km2 may give undesirable stream network delineation for other watersheds.> 
 

Now, click on Create streams option (#3) to start the process of generating the stream network [if 

you get a message regarding MPI program is not found, press OK. Also if you get other warnings 

or messages related to firewall access, simply cancel those messages for the program to proceed]. 

You will see that the tool is creating flow direction grid, flow accumulation and the stream network 

based on the information provided. Open the attribute table of the stream features and check the 

fields that are added to the attribute table. How many streams features are populated for this DEM? 

 

We will use a point feature (add if it is not present in the map : cedar_outlet.shp) to create an outlet 

point on the stream network. Zoom in to the outlet as much as possible. Now, click on Draw 

inlets/outlets (#4). Select a point (upstream of outlet, close to the streamline) on the map along the 

stream, and press OK in the intermediate window.  

               
 

If the delineated point does not fall on the stream for some reason, the threshold distance specified 

in the Snap threshold option should pull the point towards the stream. Use default 300 m and click 

on Review snapped (#5).  You will get a message in this case as “1 snapped”. Now, click on Create 

watershed (#6) and the watershed polygon feature class with sub-basins will be created and added 

to the map display as shown below. What happened to streams outside the watershed? 
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Open the attribute table of  the watershed and you will see  different fields that are created and 

populated in the table. Also, it does not have any hydrology or watershed specific attributes (e.g., 

slope, elevation). The Sub-basin field also has Null values. Let us leave the other two options 

default (Merge subbasins & Add reservoirs and point sources). Finally, press OK (#7) at the 

bottom of the window. If you again open the attribute table, you will see that Subbasin field is 

populated. How many sub-basins are created with the specified threshold? Close the attribute table. 

 

You are done with delineating the watershed and creating sub-basins for a specific threshold area. 

Save your project. In the QSWAT main form, you will notice that the status of Step 1 is changed 

to Done and Step 2 Create HRUs is now active as shown below (but Step 3 is still inactive).  

 

  
 
After you are done with watershed delineation, the next step is to create HRUs by using land use, 

soil and elevation (slope) information.  
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HRU Analysis 

Once, you have completed the Step 1 – Delineate Watershed, the Step 2 – Create HRUs will be 

activated. Now, click on Create HRUs and new window opens. We have to provide input related 

to three different data: 

a) Landuse Raster 

b) Soil Raster 

c) Slope Definition 

 

  
 

Click on the Select landuse grid button (#1 in the figure above) to load the landuse data 

(cedar_lu.tif) and change the landuse table to Use csv file option (#2). Land use data typically 

comes with numbers (values) for each land use type so we will use a look-up table to relate these 

numbers to specific land use types. Now, load the soil map (#3) and check the 

SSURGO/STATGO2 option (#4). In this exercise, we are dealing with soil map from STATSGO2. 

Unlike, usersoil and STATSGO options, SSURGO and STATSGO2 do not require a lookup table.  

 

The next step is to assign slope attributes to each HRU. Now, in the text box for slope, enter value 

of 10 (#5). It would create two bands for slope, namely 0-10% and 10% & more. Click on Insert 

(#6) to introduce the value between 0 and 9999.  After checking the box for Generate FullHRUs 
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shapefile, click on Read (#7). In the browse window, load the landuse lookup table (available in 

the data folder - lu_nlcd2011.csv).  

 

[There is also an option Read from previous run. This can be used when re-running the project, provided 

you have not re-run the delineation step, and not changed the soil or landuse inputs, to recover information 

from the project database instead of rereading the grids or maps. Reading from the project database 

(database created in previous run) is substantially faster.] 

HRU Threshold Definition 

 

To create HRU by using the combined land use, soil and slope data, we have to input the threshold 

in either percentage or area. Let us now define the threshold for landuse, soil and slope as shown 

below. Depending on the version of QSWAT, you may have to push the Go button after specifying 

one threshold and then move on to another data. After the thresholds are specified, push the Create 

HRUs button. 

 

 
 

After the process is completed, you can view the report on HRU creation.  
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In the report, you will see that several (around 100 +/- 10) HRUs with unique combination of 

landuse, soil and slope are created for the study area. These combinations are listed under each 

subbasin in the report. 

 

Creating Input Files/Tables  
 

After all geo-processing is done on DEM, land use, and slope data to create sub-basins and HRUs, 

the next step is to create input files for SWAT including weather data. Now click on Step 3 – Edit 

input in the QSWAT main form. 

 

  
 

Once the SWAT Editor window is open, check whether Soil Database (#1 below) is selected as 

SWAT_US_SSURGO_Soils.mdb (this was manually added to C:\SWAT…..as we are using 

STATSGO2 soil data). Make sure the locations of these databases are correct. Press Connect to 

Databases (#2 below). This process will connect the data in the map to the SWAT database. Now, 

you will get a message indicating that the connection was successful and the drop-down menus 

are activated (Write Input Table, Edit Swat Input, and SWATSimulation menu). 

 



 10 

  
 
There are four connections addresses in this window. The first one indicates the address to project 

geodatabase which is located in the project folder. The second one is associated with SWAT 

Parameter geodatabase. It cloned from the QSWAT database located along with the installation 

folder. The third one refers to soil database. In this exercise, we manually added this file for using 

STATSGO2 (or SSURGO) soil data. The last one refers the location of SWAT Executable folder.  

 

 

Create Weather Input (using weather generator for this class) 
 

To create weather input for SWAT, click on Write Input Tables→Weather Stations 

 

 
 

There are two options to input weather data. The first option is to use the weather geodatabase 

from SWAT, and the second option is to use your custom database. For this exercise, we will just 

use the internal weather geodatabase within SWAT. In the Weather Generator Data tab, select 

WGEN_US_COOP_1980_2010 from the locations table drop down menu to load the data.  
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Next, in the Rainfall Data tab, leave the Simulation option checked with daily precipitation time 

step. The selection of “Simulation” option will tell the program to generate weather data from the 

internal weather generator within SWAT. For other weather variables, including temperature, 

relative humidity, solar radiation and wind speed, leave the Simulation option checked. 

 

 
 

Finally, click OK. This will create a weather database for the study area. [If you get a warning 

message stating GetOleDbSchemaTable, ignore the message by clicking OK]. Then, you will get a 

message that processing is complete. Now, click OK on the dialogue box. 

 

 

Weather Data (using observed precipitation - for your class project) 

 

First, create a precipitation (pcp file) and temperature (tmp file) data for your watershed. A typical 

examples for creating weather input files can be obtained at:  

C:\SWAT\SWATEditor\Databases\ExInputs. 

 

To use observed rainfall data, click on Rainfall Data, check the Raingages option, and browse to 

the pcp file. Click OK. 

 

To use observe temperature data, Click on Climate Station, and browse to tmp file. Click OK. 
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All other weather files (solar radiation, relative humidity, wind speed) can be used from  SWAT 

weather generator. 

 

Now, click on Cancel in the Weather Data Definition window. 

 
SWAT Input Files 

 

After generating weather database, you can create all other input files by selecting Write Input 

Tables→ Write SWAT Input Tables.  

 

  
 

A new window named as Write SWAT Database Tables will be displayed. Click on Select All and 

then click on Create Tables. 
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Choose Yes in all the subsequent messages which may show up. You should get a final message 

saying all input tables were created. Now you are ready to run the simulation! Click on Cancel to 

exit the window 

 

Running SWAT Simulation 
 
Click on SWAT Simulation→Run SWAT 

 

Set the period of simulation from 01/01/2004 to 12/31/2010 and change the printout settings to 

daily, and leave other default options unchanged. NYSKIP means model simulation warm-up 

period and for this tutorial, we will use NYSKIP as 1 year. Click on Setup SWAT Run. You will 

get a message indicating SWAT Setup is finshed. Now, click on Run SWAT.  
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While SWAT is running, you will see a DOS window showing you the progress, and after the 

simulation is done, you will get a final simulation completion message.  

 

 
 
After getting a successful simulation message, close the SWAT simulation setup window. You are 

now ready to read and visualize the model output. 
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Error Checking 

 
The SWAT Error Check tool can be used to find out issues with the modeling in the early stage. It 

enables us to find out any hidden problems and reduce the time in regenerating or recalibrating the 

model at a later stage. SWAT Check performs mainly three operations: (i) it reads the output and 

notify the users if the values lie outside the possible limits, (ii) it produces process-based figures 

for quick visualization, and (iii) also find and notify the common model errors.  

 
Click on SWAT Simulation→Read SWAT Output 

 

 
 

Select output.rch as shown above (#1), and click on Import Files to Databases (#2). Also, SWAT 

simulations can be saved using the Save SWAT Simulation with a user input name. Type in 

simulation name as Model1 (#3) and press on Save Simulation. This may be useful when you 

change the parameters during the calibration and validation of the model. Finally, click on Run 

SwatCheck option.    
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In the SWAT Error Checker option, change the Project Location to Model1 (saved in the earlier 

step). Click on Examine Model Output option to read the output from SWAT Project. This will 

examine the simulation and create different statistics related to the project. The watershed area 

might be different based on outlet selection in Delineation step. 

 

Once it is finished, click on Hydrology to get a watershed view for the selected simulation as 

shown below. 
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Visualization with QSWAT 

 
After running the model and error check, Step 4 Visualize will be added to the QSWAT main 

form. Click on Step 4 – Visualise in the Main QSWAT form as shown below. 

 

  
 
There are three possibilities for visualization: Static data, Animation and Plot. For Static data 

option, a single summary value is calculated for each sub-basin, reach, or HRU and displayed as a 

map. For Animation option, we can view the animated display of the value in each sub-basin, 

reach, or HRU at each time step in the map display. Plot option supports the creation and display 

of plots of selected variables. First, let us look at Static data option. 
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Follow the steps shown in figure above and finally press on Print option. This will open QGIS 

Print Composer. This allows us to make a map of the SWAT project. The output for this option is 

shown below. You can add different features to the map by selecting feature in Layout option.  

 

   
 

Next, let us use the Animation option to see the animation in the QGIS Desktop (Map canvas/ 

document). 
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There are controls to run, pause and rewind the simulation: it steps through daily, monthly or 

annual time steps according to the reporting period chosen for the simulation. The speed of the 

animation can be adjusted using the Speed option. You can also record the animation. You would 

see the animation in the map window. You can increase the speed to 10 [if you do not see the 

changes happening in the map document]. 

 

Now, we will use Plot option as shown below.  

 

  
 

After you press the Plot option, save it as csv file with a suitable name. The graph for the exercise 

would look similar to below. If you have observed data for your watershed, you can include it in 

Choose observed data file option. Also, you can use the Save button to save the plot in different 

formats. 
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Manual Plotting of SWAT outflow in MS Excel 

 
You can also create a plot by manual method. Find a folder named as TxtInOut inside the 

Scenarios folder, which holds most of the input/output information for the model that you just 

created. Choose the Model 1 folder (remember you have saved your first simulation as Model 1 in 

an earlier step) in the Scenarios folder.  

 
 

Inside the TxtInOut folder, find a file that is called output.rch. Once you know where this file is 

located, start any spreadsheet software (here we will use MS Excel) and browse to open output.rch 

file. When you try to open the file using MS Excel, make sure you choose “All Files” option and 

then select output.rch. 

 

Open output.rch using “delimited” and “space” as options as shown below. You will then see the 

output.  

 
 

Depending on how many reaches (or streams) you have in your model, each reach will have a time 

series of streamflow. This streamflow is stored in the “FLOW_OUTcms” (flow output in cubic 

meter per second) column. You will also see a column called “Area_KM2”. This column shows 

the area draining to each reach. The reach that has the maximum area is your most downstream 

stream. Now, filter your data to only include the rows that has the maximum area. Simply copy 
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the “FLOW_OUTcms”, paste it in another sheet. If you want you can copy the date next to these 

values as well. Once  you have this, you can create a chart of day (x axis) and flow output (y-axis). 

This will be your hydrograph for the duration of your simulation.  

   

Your plot should have a good title and appropriate labels for x and y axes.  

 

OK, you are done with the QSWAT tutorial! Congratulations!! 

 

 


