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Introduction 

The objective of this exercise is to learn basic functions in HEC-RAS to create a 1D steady 

state model. It is expected that you are familiar with 1D St. Venant’s, energy, and 

Manning’s equations. Although you will not need these equations, but they are used behind 

the scenes. If you want to get into details of HEC-RAS that are not covered in this tutorial 

please refer to the HEC-RAS users manual.  

Pre-requisite: Watch the Introduction to 1D Hydraulic Modeling video at: 

https://www.youtube.com/watch?v=o9bwunC4G7A 

Learning Outcomes 

• Creating a simple 1D HEC-RAS model/project 

• Creating a single reach geometry for HEC-RAS 

• Running 1D steady state simulation in HEC-RAS 

• Run HEC-RAS simulation 

• Visualize HEC-RAS results 

Student Time Required: 50 mins 

Computer Requirements 

You must have a computer with windows operating system with HEC-RAS 5.0.x 

installed. You can download HEC-RAS and related documents for free from the US 

Army Corps of Engineers Hydrologic Engineering Center website 

https://www.hec.usace.army.mil/software/hec-ras/  

Data Requirement 

None.  

Instructions 

Start HEC-RAS 

mailto:vmerwade@purdue.edu
https://www.youtube.com/watch?v=o9bwunC4G7A
https://www.hec.usace.army.mil/software/hec-ras/
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In most typical installations on windows system, you go to 

Start→Programs→HEC→HEC-RAS 5.0.x. This path may be different in computer labs. 

Just search for HEC-RAS and open the program. 

HEC-RAS Interface 

 

The interface consists of a list of menu (File, Edit, Run, etc.) on the top, followed by a list 

of tools (which are a subset of few key items from the menu) and a list of files (Project, 

Plan, Geometry, Steady Flow and Unsteady Flow). The description box (bottom) can be 

filled with whatever description you want for the project. By default, the units are US 

Customary, which can be change b going to Options in the Menu bar and changing the 

Unit System. 

Creating and Saving HEC-RAS Project 

Save the project by going to File→Save Project as.. name the project as ras1 in a folder of 

your choice. If needed, you can use the Create Folder option to create a new folder and 

save the project inside that new folder. 

 

After the project is saved, you will see that the Project box in the list of files gets filed 

with ras1 and its location is also displayed on the interface. A HEC-RAS project file is 

saved with .prj extension (note: a GIS projection file also has .prj extension, but both files 

are very different!). Lets also go ahead and provide some description for the Description 

box. 
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Creating and Saving Geometry File 

Once we create the project, the next step is to define the river geometry. A 1D river 

geometry file describes the shape of a river using, at bare minimum, the river centerline, 

cross-sections (location and shape) and bank points.  The geometry file will also include 

information on Manning’s n values for each cross-section. Go to Edit→Geometry Data.. 

to open the Geometry Data Editor. Within the Geometry Data editor, go to file and save it 

using the Save Geometry Data option. 

 

You do not have to provide any name for the geometry file. By default, the geometry file 

gets the name of the project, and the extension of the file is .gxx, where g stands for 

geometry and xx is a number. Your first geometry file gets saved as ras1.g01. You can 

give some title (Geometry File) if you want. After you save the geometry file, you notice 

on the HEC-RAS interface that the geometry box is populated similar to the project box. 

Populating Geometry File 

The geometry editor has a file menu (File, Edit, Options, View, etc) on top, a list of tools 

to create River Reach, Storage Area, 2D Flow Area, etc. below the file menu, a list of 

editing tools to edit junction, cross-sections, bridge/culvert, etc. on the left and the 

geometry window (blank white area).  

Create River/Reach or Centerline 

Use the River Reach tool and create a single diagonal reach in the geometry window by 

starting at the top left corner (upstream end) and ending in the lower right corner 

(downstream end). Single clicks will create/digitize the reach and double click (at the 

downstream end) will finish the digitization as shown below. 
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As soon as you double click, you will be prompted to enter the River and Reach names as 

shown below. Use Wabash for river name and West Lafayette for reach name. Wabash 

River runs through West Lafayette, where Purdue University is located, but here we are 

creating a hypothetical reach! 

 

Another very important point to note is that the geometry we are digitizing is not geo-

referenced, which means you cannot export the geometry and try to put on a map to 

match the actual location of Wabash River in West Lafayette. You will learn on how to 

create a geo-referenced HEC-RAS model later. After you enter the river/reach names, 

you will see that the reach is created and the flow direction (arrow) is displayed in the 

geometry window. Note: River/Reach are always digitized from upstream to downstream 

direction in HEC-RAS. 

Save the geometry file. 

Create Cross-Sections 

Click on the Edit/Create Cross-Section button on the left to get an empty cross-section 

editor. In the cross-section editor, go to Options→Add a new cross section. The program 

will ask you to enter a “River Station” for this cross-section. A river station is basically a 

upstream 

downstream 
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location along the reach. For example, a river station of 50 will mean a point along the 

river reach at a distance of 50 units from the most downstream point. As our reach is not 

geo-referenced, a unit of 50 does not mean anything. To make it little more logical, lets 

use a station of zero (0) so our first cross-section gets created at the most downstream 

location. 

 

You will see that an empty cross-section at station zero is created. Our next step is to 

populate the cross-section with the ground profile by providing a series of 

Station/Elevation values. Use the following values to create a cross-section that is 1000 ft 

wide by entering the data in the Station/Elevation columns. As our project is created in 

US Customary units, the values are in ft. 

Station (ft) 0 300 400 400 600 600 700 1000 

Elevation (ft) 600 580 575 570 570 575 580 600 

After entering the values, use the “Apply Data” button and you will see a nice looking 

symmetric cross-section. The cross-section as the main channel of rectangular shape 

between stations 400-600, and the rest is the floodplain on each side. Next you will see 

that there are more empty boxes for downstream reach lengths, Manning’s n values and 

Bank Stations. Since this is our most downstream cross-section (Station = 0), lets leave 

the downstream reach lengths empty. Use a value of 0.035 for LOB/ROB Manning’s n 

values and 0.015 for Channel. Use Bank Stations as 400 and 600 for left and right bank, 

respectively. Use the apply data button and your cross-section should look something like 

below. You will notice the bank points as red dots at stations 400 and 600, and also the 

distribution of Manning’s n on top for the main channel and floodplains. 
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Save your project/geometry data. 

If you are happy (I am sure you are!), lets create the most upstream cross-section. As our 

reach is not geo-referenced, a station of zero will create cross-section at the most 

downstream location and a station of 100 will create a cross-section at the most upstream 

location.  

Now that you know how to create a cross-section, you can follow the same procedure to 

create as many cross-sections as you want using Station/Elevation values. However, to 

keep things simple, we will replicate the same shape and properties for all cross-sections 

along the reach. In the cross-section editor, go to Option→Copy Current Cross Section… 

All you have to do is enter the station number (100 in this case) 

 

For the new cross-section we will also specify LOB/Channel/ROB downstream reach 

lengths as 500 ft. Press Apply Data button. After you create/copy the second cross-

section at station 100, go back to the geometry editor to see the newly created cross-

sections as shown below. If you do not get the complete view of the cross-sections in the 

geometry window, go to View→Set Schematic Plot Extents.. and change the extent to 

“Set to Computed Extents” and press OK. You can do this every time you want to set the 

extent to see the entire geometry. 

Apply data button 
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You should then see your two cross-sections (one at the most u/s end and other at the d/s 

end). You will see that the stationing along the River/Reach increases from downstream 

to upstream as the zero station cross-section is located at the downstream end. With 

respect to cross-sections, the station/elevation values are plotted from left to right looking 

downstream along the flow direction.  The bank points are presented as red dots in the 

geometry window. 

 

Repeat the same procedure of copying cross-sections to create three more cross-sections 

at stations: 25, 50 and 75. Exit cross-section editor. You should now see five cross-

sections along the reach as shown below. 
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Since our data are not geo-referenced, the stationing along the reach is only 

proportionately applied here, but the stationing along the cross-sections is in feet as we 

need this information in proper units to compute cross-sectional areas and flow 

conveyance. Also the distance specified in the LOB/Channel/ROB is in feet for 

computing the loss term in the energy equation. Thus, technically our reach is 2000 feet 

long. Close the cross-section editor, save the geometry file and exit the geometry editor. 

Now that the geometry is ready, we can specify a discharge value and let it flow through 

the reach to get the water depth or elevation and velocity at each cross-section. 

Creating Steady Flow File 

Discharge value(s) in HEC-RAS are specified using a Steady/Unsteady Flow file. In this 

lab, we will create a steady state simulation. Steady state means the flow is not changing 

with time so we will use only one value. Typically, for most design purposes, when we 

have the discharge hydrograph, we will use the peak value to simulate the river 

hydraulics in HEC-RAS. To create a steady flow file, in the main HEC-RAS interface, go 

to Edit→Steady Flow Data.. 

You can enter some description (Steady Flow File for Wabash Reach). We will supply an 

upstream boundary condition of flow or discharge at Station 100 as 20,000 cfs. Press 

“Apply Data” button. PF 1 stands for profile flow 1. You can use the “Enter/Edit Number 

of Profiles” box to enter the number of profiles or flow values, but in the lab we will only 

create one flow profile. 
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Next you will use the Reach Boundary Conditions.. (highlighted in the figure above) 

button to specify the downstream boundary condition at station zero. We will use a 

simple “Normal Depth” boundary condition and specify a bed slope of 0.001 as shown 

below. 

 

Press OK for both boundary condition window and save the steady flow data by going to 

file save flow data. In the main HEC-RAS interface, you will now see that ras1.f01 (f for 

flow and 01). Once the flow data are complete, the model is ready for simulation! 

Running Steady State Simulation 

To create a steady flow simulation, on the main HEC-RAS interface, go to Run→Steady 

Flow Analysis. As soon as you do this, a plan file also gets created and it stores the 

Flow value 
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geometry and flow information used in running the simulation. The main HEC-RAS 

interface will show this plan file. In the Steady Flow Analysis window, change the flow 

regime to “Subcritical”, and press the Compute button.  

 

It should take only a few seconds to complete the simulation.  

 

We can now visualize the results. 



 
11 

Visualizing HEC-RAS Results 

Cross-sectional View: This can be done using the cross-section view button (shown by 

arrow below) on the main HEC-RAS interface.  

 

In the cross-sections view window, you can change the station number to see the water 

level at different cross-section.  

Profile View: This can be done using the profile view button (shown by arrow below) on 

the main HEC-RAS interface. 

 

Tabular View: There are two options. The first option is to view the Summary Output 

Table for the entire profile by using the summary table output button (shown by arrow 

below). This gives an overview of channel average properties for each cross-section in 

one table. 
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The second tabular view is the detailed output at each cross-section by using the detailed 

cross-section output button (shown by arrow below).  

 

 

You can also view a xyz (3D) profile plot by using the 3D output button as shown below: 
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Save your project. Okay, you are done with your first Introduction to HEC-RAS tutorial! 

Congratulations!! 

Homework 

1. Report the average water surface elevation for the entire profile (reach) in ft for your 

simulation. 

2. Keeping the Manning’n for floodplain at 0.035, change the channel Manning’s n to 

0.03 for all cross-sections and report the average water surface elevation for the 

profile in ft. 

3. Keeping the channel Manning’s n for channel to 0.015, change the floodplain 

manning’s n for all cross-sections to 0.06 and report the average water surface 

elevation for the profile in ft.  

4. Discuss how the change in Manning’s n for the channel and floodplain affected the 

water surface elevation. Was the water surface elevation more sensitive to channel 

manning’s n or floodplain manning’s n? why? 

5. Repeat 2 and 3 above with a steady flow of 100,000 cfs. Discuss how the change in 

Manning’s n for the channel and floodplain affected the water surface elevation. Was 

the water surface elevation more sensitive to channel manning’s n or floodplain 

manning’s n? why? 

 

(Note: Look at the video to see how Manning’n can be changed for all cross-sections at 

once) 


